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About Xftp 
Xftp is a powerful SFTP and FTP file transfer program operating on the Windows platform. 
Windows users can transfer files securely and conveniently with UNIX/Linux host using Xftp. 
SFTP (Secure Shell File Transfer Protocol) supports encryption and user authentication for 
secure Internet connection and can replace conventional file transfer protocols, such as FTP.  
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Key Functions 
General 

• Supports SFTP (SSH2 only) and FTP protocol 
• Supports Windows 2000/XP/2003/Vista/2008/7/8  
• Supports virtual environments  
• Supports OpenSSH, ssh.com server and SSH servers that follow SFTP protocol 

standards 
• Multi-user setting 
• Keep alive option 
• UTF-8 character strings 
• Diverse proxy servers 
• Supports FXP for direct transfer between servers 

Session Management 

• Creates and manages session files for different hosts  
• Supports Sessions dialog box, quick connect bar, shortcut to session and links bar to 

open a session 
• Provides default session for quick connect  
• Supports URL command in quick connect bar and connection to remote host without 

opening a saved session 
• Shows folders and trees in Sessions dialog box 
• Automatically connects with the session which is open at program exit 

Security 

• RSA/DSA public key, password and keyboard interactive user authentication  
• RSA/DSA new user key wizard and import/export key 
• AES128/192/256, 3DES, BLOWFISH, CAST128, ARCFOUR and RIJNDAEL encryption 

algorithms 
• SHA1, SHA1-96, MD5, MD5-96 and RIPEMD160 MAC algorithms 
• zlib compression 
• Host keys dialog box 
• User keys dialog box 

Appearance 

• Simple and powerful user interface 
• Multiple tabs, multiple tab group 
• Customizable Standard Buttons on toolbar 

File Transfer 
• Transfers files simultaneously  
• Resumes downloading 
• Pause transfer 
• Resume for failed transfers 
• Shows transferred folder in tree view 
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• Shows graphical transfer status 
• Supports folder synchronization between remote and local folders 

File Management 

• Supports direct editing of remote files 
• Manages several local folders 
• Deletes and renames files 
• Creates new folders 
• Executes files 
• Changes permissions 

Interoperability  

• Interoperable with Windows Explorer 
• Interoperable with Xshell program 
• Interoperable with Xagent program 

Recommendations 
• Operating System: Microsoft Windows® XP SP3 or higher 
• Storage Space:  Reserve space of 50MB or more 
• Network:  TCP/IP network 
• Program:  Internet Explorer® 6.0 or higher 

Install and Uninstall 
The Xftp installation program was created using InstallShield®. A variety of installation options 
can be changed in the course of installation. It is sufficient in most cases to simply click [Next].  

To uninstall Xftp, use standard Windows add/remove features. Run [Add/Remove Program] 
and select in the control panel to uninstall Xftp or Xmanager Enterprise from the list. Note 
that when Xmanager Enterprise is uninstalled, programs other than Xftp are also removed.  

Even when the program is uninstalled, the registry information, log files and user created data 
files are not removed. Such information and files are available for reuse when the program is 
reinstalled. If you want to remove all the files and registry information completely, remove the 
following explicitly: 

Registry Information: 
• \HKEY_CURRENT_USER\Software\NetSarang\Xftp 

• \HKEY_CURRENT_USER\Software\NetSarang\Xmanager Enterprise 

File and Folder: 
• %APPDATA%\NetSarang\Xftp 

• %APPDATA%\NetSarang\Xmanager Enterprise 
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Start 
This section provides descriptions on creating an SFTP or an FTP session and exchanging files 
by connecting with a UNIX/Linux host. The FTP session is very simple. The SFTP session 
however, occassionally requires user key registration in the server before connecting. If user 
key registration is necessary, see ‘Public Key User Authentication’.  

Create Session 
1. Select [New] in the [File] menu. A New Session Properties dialog box is displayed. 

 

Fig. 1: New Session Properties dialog box 

2. Enter session name in the [Name].  
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3. Enter host name or IP address in the [Host].  
4. Select an appropriate protocol from the [Protocol] list.  
5. Enter port number used by remote server in the [Port Number].  
6. Enter user account of server in the [User Name]. 
7. Click [OK]. 

Connect to Remote Host with SFTP 
When an SFTP session has been created, connection can be made with a remote host using the 
SFTP protocol. If there are no sessions created, see ‘Create Session’ first.  

1. Select [Open] in the [File] menu. Sessions dialog box is displayed. 
2. Select a session for connection and click [Connect]. SSH User Authentication dialog box 

is displayed.  

  

Fig. 2: SSH User Authentication dialog box 

3. For Password authentication, enter a password in the [Password] box and click [OK].  
4. For Public Key authentication, first select a user key from the list. Enter the passphrase for 

the selected user key in the [Passphrase] box and click [OK].  

 Note 

If user key is not available, see ‘Public Key User Authentication’.  

5. For Keyboard Interactive authentication, click [OK] and answer the questions given during 
the connection process. 
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Connect to Remote Host with FTP 
When an FTP session has been created, connection can be made with a remote host using the 
FTP protocol. If there are no sessions created, see ‘Create Session’ first. 

1. Select [Open] in the [File] menu. Sessions dialog box is displayed. 
2. Select a session for connection and click [Connect]. FTP User Authentication dialog box 

is displayed.  

 

Fig. 3: FTP User Authentication dialog box   

3. Enter user name in the [User Name] box, enter password and click [OK].  

Transfer File 
Transfer Files from Remote Server to Local PC 
1. Select files to download from the remote folder window. 
2. Drag the selected files to the local folder window.   

Transfer Files from Local PC to Remote Server 
1. Select files to upload from the local folder window. 
2. Drag the selected files to the remote folder window. 

Transfer Files between Local Folders 
1. Select files to transfer from the local folder window. 
2. Drag the selected files to the local folder window of another tab group.  

Transfer Files between Remote Folders  
1. Select files to transfer from the remote folder window. 
2. Drag the selected files to the remote folder window of another tab group.  

 Note 

Transfer files by clicking the left or right arrow buttons of the standard buttons. 
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Move Tab to another Tab Group 
1. If there is only one tab group, create a new tab group via the method shown in 2 below.  
2. To create a new tab group, drag tab toward the right border of a tab group.  

A guideline is displayed at the position to which a tab is to be moved, and when the mouse 
is over the guideline, a new tab group is created, including the selected tab.  

 Note 

You can create a new tab group by selecting [New Vertical Tab Group] in the [Window] 
menu.  

3. If there are two or more tab groups, a tab can be moved by dragging it to another tab 
group.  

Exit Xftp 
To close the tab, click its Close button or click [Close] in the [File] menu.  
To end Xftp, select [Exit] in the [File] menu. 
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Session Management 
A ‘session’ is a file containing information about remote host connection setup. By creating a 
session, a user can set different options for different remote hosts. The Sessions dialog box 
shows all sessions created and enables the creation and editing of sessions.  
A user can connect to a remote computer without creating a session. For this purpose, Xftp 
provides a default session which can be used concurrently with installation.  

Session Management 
To Create a New Session: 
1. Open the New Session Properties dialog box.  
2. Enter connection information.  
3. Click [OK].  

To Open the Sessions Dialog Box: 
• Select [Open] in the [File] menu. 
• Click the standard [Open] button.  

To Edit a Session: 
1. Open the Sessions dialog box.  
2. Select a session to edit.  
3. Click the standard [Properties] button. 
4. Click [OK] after completing session editing.  

To Rename a Session: 
1. Open the Sessions dialog box.  
2. Right-click on a session to rename.  
3. Select [Rename] in the menu.  

 Note 

A session name must be a valid file name.  

To Copy a Session under a Different Name: 
1. Open the Sessions dialog box. 
2. Select a session to copy under a different name.  
3. Click the standard [Save As] button.  

To Delete a Session: 
1. Open the Sessions dialog box.  
2. Select a session to delete. 
3. Click the standard [Delete] button.  

To Create a Shortcut to a Session: 
1. Open the Sessions dialog box.  
2. Select a session for which the shortcut will be created.  
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3. Click the standard [Create Shortcut] button.  
4. Select a folder in which to save the shortcut.  
5. Click [OK]. 

To Change Default Session Properties: 
1. Move to the local folder tab or close all remote folder windows.  
2. Select [Properties] in the [File] menu. The default Session Properties dialog box is 

displayed.  

 Note 

Default session is used when connecting with SFTP and FTP via the quick connect bar.  

To Create a New Session Folder: 
1. Open the Sessions dialog box.  
2. Select [Folder] from the list displayed when the arrow button next to the standard [New] 

button is clicked.  
3. Enter folder name.  

To Copy a Session File to Another Computer: 
1. Open the Sessions dialog box. 
2. Click the standard [Open Session Folder] button.  

3. Copy session file (*.xfp) or e-mail it to another computer.  

4. Save session file in the following folder:  
"%APPDATA%\NetSarang\Xftp\Sessions"  

Session Properties 
Open a Session Properties dialog box to edit a session or create a new session .  

To Open Session Properties dialog box: 
• Select [New] in the [File] menu. 
• Select [Properties] in the [File] menu. 
• Click the standard [Properties] button.  

General Tab 
Information about session connection can be set up under the general tab. In most cases, 
users can connect with a remote host just by setting information about the session connection.  

Name 
Enter a name unique to this session. The name becomes the name of the session file. It must 
be composed of characters valid for use in a file name.  

Host 

Enter remote computer host name or IP address.  

Protocol 

Select a protocol to use when connect to a remote computer. Supported protocols are SFTP 
and FTP.   
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Setup 

Set detailed options when using the SFTP protocol. For detailed information, see ‘SFTP 
Advanced Options Dialog Box.  

Port Number 

Enter the port number of the protocol selected above. When a protocol is selected from a list of 
protocols, the default protocol port number is automatically entered. If the remote computer is 
using another port number,  the user must directly enter a port number. The defaults are 22 
for SFTP and 21 for FTP.  

Proxy Server 

Select a proxy server to use in the connection. 

Anonymous Login 

Login as an anonymous user. This function is available only in FTP protocol.  

Use Authentication Agent 
Authentication is attempted with Xagent for SFTP connections. Xagent is an SSH 
authentication agent. Xagent keeps user keys used for public key user authentication and lets 
Xftp use it when it requires a user key. 

Method 

Select a method to authenticate users on remote computer. 

User Name 

Enter the user login name. This name is the remote computer login account. If this is left blank, 
a dialog box requesting a user name appears during connection.  

Password 

Enter the remote computer user password. If this information is left blank, a dialog box 
requesting user authentication appears during connection. The password is encoded and saved 
in the user’s PC. Keep this information blank for greater security.  

User Key 

Select a user key to be used when public key authentication is selected in the SFTP protocol. If 
this information is left blank, a dialog box requesting user authentication appears during 
connection. If there are no user keys in the list, a key must be created first and be registered 
in the remote SSH server. 

Passphrase 
Enter the selected user key passphrase. The entered key passphrase is encoded and saved in 
the user’s PC. Keep this information blank for greater security.  

Options Tab 
Under the options tab, detailed session options can be set. In most cases, users are not 
required to set options.  

Host Type 
Select the type of remote computer operating system. Select [Auto Detect] if the remote 
computer type is unknown.  
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Use UTF-8 Encoding 
Communicate with a remote computer using UTF-8 character strings. This option must be 
selected when the remote computer uses UTF-8 character strings and the remote computer 
files hold character strings encoded in UTF-8. 

Send Keep Alive Messages 
Send keep alive messages to remote computer. This function is useful when connection is 
unexpectedly closed while connection is idle. In some network environments, the gateway or 
firewall system forces a disconnection if data transfer is not made for a prescribed period of 
time.  

Use Passive Mode 
Connect with remote computer in passive mode at file transfer. For details, see ‘Connection in 
Passive Mode’. This option is not necessary when SFTP connection is selected. 

Transfer Type 

Designate the type of file transfer in this session. For details, See ‘Set Transfer Types’.  

Multiple Transfer 
Designate the number of files to be transferred simultaneously. To use this function, server 
must support a multiple connection.  

Use Main Connection Only 
This option is designated when the server allows only a single connection. Since the main 
connection is used at file transfer, files can be transferred one by one. During file transfer, 
functions such as file list refreshing cannot be used. This option is not necessary when SFTP 
connection is selected.  

Local Folder 

Designate a folder to be displayed in the local folder window when connection succeeds.  

Remote Folder 

Designate a folder to be displayed in the remote folder window when connection succeeds.  

SFTP Advanced Options Dialog Box 
Set the various options neceesary for connection using SFTP protocol in the SFTP Advanced 
Options dialog box. Select SFTP protocol in the [General] tab of Session Properties and click 
[Setup] to open.  

Encryption 

Encryption algorithms are used to encrypt and decrypt network traffics. Users may select 
preferred encryption algorithm from the list. If <Cipher List> is selected from the list, multiple 
algorithms may be attempted in the order appeared in the list. To edit the list of <Cipher List>, 
click [Edit]. 

MAC (Message Authentication Code) 
MAC is added in SSH2 for greater security and to ensure data integrity. If <MAC List> is 
selected from the list, multiple algorithms are tried in the order appeared in the list. To edit the 
list of <MAC List>, click [Edit].  

Use ZLIB Compression  
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If network speed is slow, increase speed using ZLIB compression.  
 

Export 
Sessions exported from Xftp are made into a single convenient file. When this file is imported 
by another computer with Xftp installed, the imported sessions can be used without additional 
setup.  

To Export a Session: 
1. Select [Export] from the [File] menu. The Import/Export Sessions wizard is displayed. 
2. Select the position where the exported file is to be saved and click [Next]. The session 

export results are displayed.  
3. Click [Finish] to end session export.  

Import 
Xftp can import session files from another computer.   

To Import a Session: 
1. Select [Import] in the [File] menu. The Import/Export Sessions wizard is displayed.  
2. Directly enter the file path exported from other computer or click the […] button to select 

the exported file and click [Next]. Sessions are imported and the result is displayed.  
3. Click [Finish] to end session import.  
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Connection 
Xftp provides various connection methods, such as Sessions dialog box, links bar, quick 
connect bar and session shortcut .  

Connection without Sessions 
To Connect at the Quick Connect Bar: 
1. Select [Quick Connect Bar] in the [View] - [Toolbars] menu.  
2. Enter the host name or IP address as follows in the quick connect bar in addition to the 

protocol: 
• ftp://hostname 

• sftp://hostname 
• Host Name or IP address 

 Note 

If a protocol is not entered, a protocol decided in the default session is used.  

3. Enter user name and password. If this process is omitted, an authentication window is 
displayed according to the authentication method selected in the default session.  

4. Type Enter or click [Connect].  

 Note 

For details on the quick connect bar, see ‘Quick Connect Bar’.  
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Quick Connect Bar 
The quick connect bar allows users to connect to a server quickly using only the minimium 
information, without using a session.  

Host Name or IP Address 
Enter remote computer host name or IP address. The grammar for this is the following:  

 [protocol://][user:password@]host name[:font][/][path] 

The available protocols are sftp and ftp. The default protocol is that selected in the default 
session. The default port number by protocol is set as follows: 

• sftp: 22 

• ftp: 21 

The examples are listed below. 

Example Description 
foobar.com Connect to footbar.com via the protocol and a port 

number designated in the default session. 
sftp://kay@foobar.com/ Connect to foobar.com via the SFTP protocol. User 

account is kay and default port number is used.  
sftp://kay@foobar.com:12345/ Connect to port 12345 of foobar.com with SFTP 

protocol. User account is kay.  
ftp://foobar.com/ Connect to foobar.com via the FTP protocol. User 

account is not designated and the default connection 
port is port 21.  

 Note 

Xshell is executed when SSH and TELNET protocols are entered. The Xshell program 
must be installed on the user’s PC.  

User Name 
Enter user name for login. User name is the login account of the remote computer. If the 
information is left blank, a dialog box requesting a user name appears during connection.  

Password 
Enter remote computer user name password. If the information is left blank, a dialog box 
requesting user authentication appears during connection.  
 

Connection with Sessions 
Connect to a remote host repetitively by creating a session.  

To Connect at the Sessions Dialog Box: 
1. Open the Sessions dialog box.  
2. Select a session for connection. 
3. Click [Connect]. 

To Connect with a Shortcut: 
1. Double-click the shortcut icon of a session. 
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Disconnect and Reconnect 
It is possible to disconnect or reconnect at any time without closing remote folder window. For 
reconnection, user authentication information used in the previous connection is reused and 
therefore user authentication process is not required.  

To Disconnect: 
1. Click the standard [Disconnect] button. 

To Reconnect: 
1. Click the standard [Reconnect] button. 

 Note 

To enable reconnection, remote folder window must not be closed.  

Connection in Passive Mode 
For FTP connection, connection in passive mode is available. In passive mode, the remote FTP 
server waits for Xftp to establish the data connection Select passive mode to use Xftp inside a 
firewall. 

For Connection in Passive Mode Using a Session: 
1. Open the Sessions dialog box. 
2. Select a session for connection. 
3. Click the standard [Properties] button. 
4. Click the [Options] tab in a Session Properties dialog box. 
5. Select [Use Passive mode]. 
6. Click [OK]. 
7. Connect with session. 

For Connection in Passive Mode Using the Quick Connect Bar: 
1. Move to local folder tab or close all remote folder windows. 
2. Select one of the following methods: 

• Select [Properties] in the [File] menu. 
• Click the standard [Properties] button. 

3. Click the [Options] tab in the default Session Properties dialog box.  
4. Select [Use Passive mode]. 
5. Click [OK]. 
6. Connect from quick connect bar. 

Connection in Active Mode 
For FTP connection, connection in active mode is available. When a file is transferred in active 
mode, Xftp waits for the FTP server to establish the data connection. Transfer may fail if active 
mode is selected when using Xftp inside a firewall. 

For Connection in Active Mode Using a Session: 
1. Open the Sessions dialog box. 
2. Select a session for connection. 
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3. Click the standard [Properties] button. 
4. Click the [Options] tab in a Session Properties dialog box. 
5. Clear [Use Passive mode]. 
6. Click [OK]. 
7. Connect with session. 

For Connection in Active Mode Using the Quick Connect Bar: 
1. Move to local folder tab or close all remote folder windows. 
2. Select one of the following methods: 

• Select [Properties] in the [File] menu. 
• Click the standard [Properties] button. 

3. Click the [Options] tab in the default Session Properties dialog box. 
4. Clear [Use Passive mode]. 
5. Click [OK]. 
6. Connect from quick connect bar. 

Set Startup Folder 
Remote and local startup folders will be displayed when session connection is established 
successfully. Setup of a frequently used folder as a startup folder is recommended. 

To Set Local Startup Folder: 
1. Open the Sessions dialog box.  
2. Select a session.  
3. Click the standard [Properties] button.  
4. Click the [Options] tab in a Session Properties dialog box.  
5. Select one of the following methods: 

• Enter startup folder in the [Local Folder]. 
• Click […] and select a folder from the Browse For Folder dialog box. 

6. Click [OK]. 

To Set Remote Startup Folder: 
1. Open the Sessions dialog box. 
2. Select a session. 
3. Click the standard [Properties] button.  
4. Click the [Options] tab from the Session Properties dialog box. 
5. Enter startup folder in the [Remote Folder]. 
6. Click [OK]. 
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Security 
Xftp provides public key user authentication.   
Host key and user key database created in Xftp can be used in Xmanager and Xshell 
programs. Once an public key is created, it can be used in all programs without additional 
configuration.  

Public Key User Authentication 
For public key user authentication, a pair of user keys must be created, comprising a public key 
and a private key. While public key authentication is carried out, the private key is used by 
Xftp to create a user signature and the public key is used by SSH server to check the 
signature.  
A user key can be created in both the SSH server and Xftp. If the user key was created from 
the server, the private key must be registered in the Xftp private key repository using the Xftp 
import function. If the user key was created from Xftp, The public key must be registered in 
the server.  

To Create a User Key: 
1. Select [New User Key Wizard] from the [Tools] menu. 
2. Create a user key according to instructions given by the New User Key Wizard.  

 Note 

Register a public key in a server at the last stage of key creation. Registration methods 
vary depending on server types.  

• SSH1: Copy the public key text and save it to $HOME/.SSH/authorized_keys file. 
Execute the following command to turn off the write permission of the files and 
directories. 
$ cd 
$ chmod go-w . .ssh .ssh/authorized_keys 

• SSH2-OpenSSH: OpenSSH servers use this format. Copy the public key text and save 
it to $HOME/.SSH/authorized_keys2 file. Execute the following command to turn off 
the write permission of the files and directories.  
$ cd 
$ chmod go-w . .ssh .ssh/authorized_keys2 

• SSH2-IETF SECSH: Some commercial SSH servers, such as the ssh.com server, use 
this format. Save the public key under an intrinsic name, such as mypublickey.pub, 
and copy it to $HOME/.ssh2 directory. Add the following line to the 
$HOME/.ssh2/authorization file: 
  Key mypublickey.pub 
Execute the following command to turn off the write permission of the files and 
directories.  
$ cd 
$ chmod go-w . .ssh2 
$ chmod go-w .ssh2/authorization .ssh2/mypublickey.pub 
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To Register Public Key in Server: 
1. Select [User Key Manager] from the [Tools] menu and the User Keys dialog box is 

displayed. 
2. Select a user key to register. 
3. Click [Properties]. A User Key Properties dialog box is displayed.  
4. Click the [Public Key] tab. 
5. Select an appropriate type from the [Public Key Format] list. 
6. Save user key by clicking [Save as a file] or copy the key and register it to the server 

according to public key registration methods above.  

To Change User Key Passphrase: 
1. Open User Keys dialog box. 
2. Select a user key with which to change passphrase. 
3. Click [Properties]. A User Key Properties dialog box is displayed.  
4. Click the [General] tab.  
5. Click [Change Passphrase]. 

 Note 

Import, export, rename, delete and create a user key in the ‘User Keys Dialog Box’.  

User Keys Dialog Box 
The User Keys dialog box allows you to create and manage user keys. Open the User Keys 
dialog box by selecting [User Key Manager] from the [Tools] menu.  

Import 

Select and import user key files by opening an Open dialog box. Currently, Xftp can read 
SSH1 protocol RSA keys, OpenSSH SSH2 protocol RSA/DSA keys,and SSH.com and NetSarang 
user keys.  

Export 

Save the selected user key file by opening a Save dialog box. Types of exported files include 
NetSarang user keys and OpenSSH SSH2. NetSarang user key files can be used in programs 
developed by NetSarang Computer Inc.  

Delete 
Delete the selected user key from the database. 

Rename 

Change the name of the selected user key. Key name must be valid as file name.  

Properties 

Show user key attributes. Type, length, fingerprint, and public key may be viewed, and the key 
passphrase may be changed.  

Create 
Open the New User Key Wizard. 
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Host Key Management  
A host key is a remote host public key, and users can verify the host via its fingerprint. The 
remote host sends its own public key to Xftp when a connection is made. For cases where a 
host connected for the first time or where the host key is not saved in the database, a SSH 
Security Warning dialog box is displayed when connecting with the host. If the host key is 
valid and reliable, it can be saved in the host key database.  

SSH Security Warning Dialog Box 
The SSH Security Warning dialog box is displayed when the remote host key of not saved in 
the host key database or when the fingerprints of the saved host key differs from the remote 
host key. 

Accept Once 
Accept a host key for this connection only. The host key is not saved and the same dialog box 
is displayed at the next connection. This function is useful if the server host key changes 
frequently or if the server is connected frequently.  

Accept and Save 

Save host key and continue connection. This dialog box is not displayed at the next connection. 
This function is useful when the fingerprint is correct and the host is connected frequently.  

Cancel 
Host key is not accepted and connection is cancelled.  

Host Keys Dialog Box 
The Host Keys dialog box permits users to manage host keys for hosts where connection is 
allowed. The Host Keys dialog box can be opened by selecting [Host Key Manager] in the 
[Tools] menu.  

Import 

Import host keys by opening an Open dialog box. Imported host keys are saved in the host 
key database and displayed in the Host Keys dialog box. Files saved as SECSH public keys can 
be imported.  

Export 

Export the selected host key by opening a Save dialog box. The exported keys are saved as 
SECSH public keys and can be used in other programs.  

Remove 

Remove selected host key from database. 

View 
Open selected host key file with a notepad. 
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File Transfer 
Xftp provides various transfer methods, such as transfer to left/right button, drag & drop and 
copy & paste. For redundant files, it provides overwriting and continued downloading, as well 
as renaming and skipping functions. In addition, Xftp transfers several files simultaneously to 
increase overall transfer speed. For folder unit transfer, Xftp provides a function to express a 
folder list as a tree so users can easily check transfer status.  

Download 
To Download Using Menu: 
1. Select a file to download from the remote folder window. 
2. Use one of the following methods: 

• Select [Transfer to Left] or [Transfer to Right] from the [Commands] menu. 
• Right-click on the remote folder window and select [Transfer].  
• Click the standard [Transfer to Left] or [Transfer to Right] buttons.  

To Download Using Drag & Drop: 
1. Select a file to download from the remote folder window.  
2. Drag the selected file and drop it in local folder window. 

 Note 

Drag files from the remote folder window and drop them to desktop or Windows Explorer.  

To Download Using Copy & Paste: 
1. Select a file to download from the remote folder window.  
2. Use one of the following methods: 

• Select [Copy] from the [Edit] menu. 
• Right-click on the remote folder window and select [Copy].  

3. Click mouse on the local folder window.  
4. Use one of the following methods: 

• Select [Paste] from the [Edit] menu. 
• Right-click on the local folder window and select [Paste].  

To Download After Making Transfer List: 
1. Select a file to download from the remote folder window. 
2. Right-click on the remote folder window and select [Queue].  

To Resume Download Paused File/Directory: 
Select one of the following methods: 
• Right-click on the paused transfer in the transfer queue pane, and then click [Resume].  
• Right-click on the transfer queue pane and select [Resume All].  
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Upload 
To Upload Using Menu: 
1. Select a file to upload from the local folder window. 
2. Select one of the following methods: 

• Select [Transfer to Left] or [Transfer to Right] from the [Commands] menu. 
• Right-click on local folder window and select [Transfer].  
• Click the standard [Transfer to Left] or [Transfer to Right] button.  

To Upload Using Drag & Drop: 
1. Select a file to upload from local folder window. 
2. Drag the selected file and drop it in remote folder window. 

 Note 

Drag files from desktop or Windows Explorer and drop them to the remote folder window.  

To Upload Using Copy & Paste: 
1. Select a file to upload from the local folder window.  
2. Select one of the following methods: 

• Select [Copy] from the [Edit] menu. 
• Right-click on the local folder window and select [Copy].  
• Click the standard [Copy] button. 

3. Click the remote folder window.  
4. Select one of the following methods: 

• Select [Paste] from the [Edit] menu. 
• Right-click on the remote folder window and select [Paste].  
• Click the standard [Paste] button.  

 Note 

Copy a file in Windows Explorer and paste it to the remote folder window. 

To Upload After Making Transfer List: 
1. Select a file to upload from the local folder window. 
2. Right-click on the local folder window and select [Queue].  

To Resume Upload Paused File/Directory: 
Select one of the following methods: 
• Right-click on the paused transfer in the transfer queue pane, and then click [Resume].  
• Right-click on the transfer queue pane and select [Resume All].  

 

Synchronize Folder 
To Synchronize the Local and Remote Folder:  
1. Open the local and remote folders to synchronize. 
2. Click the standard [Synchronize Folders] button. The Synchronization dialog box will 
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open.  

3. Click [OK] to compare files. A list of file transfers will be displayed.  
4. Click [Transfer Now]. Synchronization starts as file upload/download is carried out.  
5. Click [Queue]. File transfer does not start immediately and the file is added to the transfer 

list. Start synchronization by selecting either [Resume] or [Resume All] from the transfer 
queue.  

Options provided in the Synchronization dialog box and Synchronization Options dialog 
box are as follows:  

Synchronization Direction 

Select one of the following: synchronize, upload, or download. 
• Local to Remote: Upload only the latest file in the local folder.  
• Remote to Local: Download only the latest file in the remote folder.  
• Synchronize: Upload and download latest file in the local and remote folders.  

Include Subdirectories 

Select this option to do recursive synchronization to all subfolders. 

Show list of files/folders before sync begins  
Show a list of destination files before starting file copy. When this option is turned off, sync files 
stand by for synchronization in the transfer queue.  

Show files including already synced 

Display a list of already synchronized files. 

Case Sensitive comparison  
Synchronization is carried out considering capital and small letters when comparing server and 
local folder files. When the option is activated, abc.txt and Abc.txt are recognized as different 
files.  

Exclude the Following Files 

Designate files to be excluded from synchronization. A number of files can be listed using ‘|’. 

Default Local Folder 

Set default path of the local folder for synchronization. 

Remember my settings 

Save settings for synchronization option.  

Transfer Queue Management 
The Transfer Queue shows file lists and transfer status as Ready, Transferring, Paused, or 
Finished. Also, it shows the logs of all transfer processes.  

To Remove All Transfers:  
1. Right-click on the transfer queue and select [Remove All].  

To Remove Some Transfers: 
1. Select files or directories to remove from the transfer queue. 
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2. Right-click and select [Remove].  

To Delete a List of Files or Directories which have Completed Transfer: 
1. Right-click on the transfer queue and select [Remove Finished Jobs].  

To Pause All Transfers:  
1. Right-click on the transfer queue and select [Pause All].  

To Pause Some Transfers: 
1. Select the file or directory to pause transfer in the transfer queue.  
2. Right-click and select [Pause].  

To Resume All Paused Tansfers:  
1. Right-click on the transfer queue and select [Resume All].  

To Resume Some Paused Transfers: 
1. Select the file or directory to resume transfer in the transfer queue.  
2. Right-click and select [Resume].  

To Retry Failed Transfer: 
1. Right-click on the transfer queue and select [Retry All Failed Jobs].  

To Check Transfer Status:  
1. Select the file or directory for transfer results checking in the transfer queue.  
2. Right-click and select [Status]. The Transfer Status dialog box is displayed.  

 Note 

The Transfer Status dialog box provides detailed information about transfers. A list of 
failed transfer files and the reasons for failure are displayed.  

Set Transfer Types 
Methods to express text file line feed characters differ according to system. When transferring 
the text files, Xftp converts line feed characters to suit the remote computer type, enabling 
users to view the text files of different systems. For non-text files, the binary file transfer type 
must be used.  

To Transfer Text Files:  
1. Select [ASCII] from [Transfer Type] in the [Commands] menu. 
2. Transfer text files. 

To Transfer Binary Files:  
1. Select [Binary] from [Transfer Type] in the [Commands] menu. 
2. Transfer binary files. 

To Transfer Files via the Automatic Transfer Type:  
1. Select [Auto] from [Transfer Type] in the [Commands] menu. 
2. Click [ASCII Extensions] in the [Transfer] tab of Options dialog box.  
3. Register file extension to be transferred via ASCII transfer type in the ASCII Extensions 
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dialog box.  

4. Transfer files. 

Set File Transfer Options 
Xftp offers overwriting, resumption, renaming, and skipping functions for redundant files at file 
transfer. Xftp also provides automatic retry options for failed transfers.  

 Note 

This setting is made in [Transfer Options] field in the [Transfer] tab of the Options dialog 
box and therefore applies to all sessions.  

To Select a Transfer Operation for Redundant Files:  
1. Open the Options dialog box.  
2. Click the [Transfer] tab.  
3. Click [Advanced Options] in the [Transfer Options] field.  
4. Select a redundant file operation from the download options in the [Overwrite File] field.  

 Note 

Options for redundant files are as follows: 
- Prompt For Action: Open the Confirm File Transfer Actions dialog box.  
- Skip: Do not transfer file. 
- Resume: Resume downloading an existing file from where it was left off. Overwrite the 
file if the existing file is larger than the file to be transfered.  
- Overwrite: Overwrite the existing file. 

To Change All Transfered File Names to Small Letters: 
1. Open the Options dialog box. 
2. Click the [Transfer] tab.  
3. Click [Advanced Options] in the [Transfer Options] field. 
4. Select [Lowercase] as the download or upload option in the [File Name] field.  

To Change All Transferred File Names to Capital Letters: 
1. Open the Options dialog box. 
2. Click the [Transfer] Tab. 
3. Click [Advanced Options] in the [Transfer Options] field. 
4. Select [Uppercase] as the download or upload option in the [File Name] field.  

To Capitalize All Transferred File Names: 
1. Open the Options dialog box. 
2. Click the [Transfer] Tab. 
3. Click [Advanced Options] in the [Transfer Options] field. 
4. Select [Capitalize] as the download or upload option in the [File Name] field.  

To Set Automatic Retry for Failed Transfer: 
1. Open the Options dialog box. 
2. Click the [Transfer] tab. 
3. Click [Advanced Options] in the [Transfer Options] field. 
4. Enter [Maxretry attempts] in the [Retry Transfer] field. 
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5. Designate a standby time from transfer failure to retry in [Retry interval].  

Resume File Download and Upload 
Files paused from transfer may continue to be downloaded. Download resumption is enabled 
when a file to transfer already exists, but its size is larger than the existing file. To resume a 
folder download, compare the sizes of all files in the folder and download only the necessary 
files. 

To Resume Downloading a File or a Folder: 
1. Select and download a file you wish to resume downloading. 
2. When the Confirm File Transfer Actions dialog box is displayed, select [Resume 

Downloading].  

To Resume Uploading a File or a Folder: 
1. Select and upload a file or a folder you wish to resume uploading.  
2. When the Confirm File Transfer Actions dialog box is displayed, select [Resume 

Uploading].  
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File Management 
With Xftp, users can execute, rename, and delete files; create new files; or directly edit files in 
a remote folder. In addition, Xftp offers the capability to edit files with an editor used primarily 
by the user. Xftp provides the same user interface as Windows Explorer so Windows users can 
conveniently manage files.  

To Execute a File: 
1. Select a file to execute in local folder window or remote folder window. 
2. Right-click and select [Open]. 

 Note 

A remote file is executed after it is downloaded to a temporary folder. When local folder is 
executed, File Explorer for the folder opens.  

To Rename a File or a Folder: 
1. Select a file or a folder to rename from the local or remote folder windows.  
2. Select one of the following methods: 

• Select [Rename] from the [Commands] menu. 
• Right-click and select [Rename]. 

3. When the input box appears, enter a new file name. 
4. Press Enter. 

To Delete a File or a Folder: 
1. Select a file or a folder to delete from the local or remote folder windows. 
2. Select one of the following methods: 

• Select [Delete] from the [Commands] menu. 
• Right-click and select [Delete]. 

3. Select [Yes] when the Delete File dialog box is displayed. 

To Change Remote Computer File Permissions: 
1. Select the file whose permissions are to be changed from the remote folder window. 
2. Select one of the following methods. 

• Select [Change Permissions] from the [Commands] menu. 
• Right-click and select [Change Permissions]. 

3. Select permissions to change from the Change Permissions dialog box. 
4. Click [OK]. 

 Note 

This function is provided via UNIX remote computers and therefore the remote computer 
operating system must be compatible with UNIX. Change permissions may fail depending 
on remote computer type.  

To Edit a Remote Text File: 
1. Select a file to edit from the remote folder window. 
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2. Right-click and select [Edit with Notepad].  

 Note 

Instead of Notepad, a customized editor can be designated by the user in the Options 
dialog box [Advanced] tab.  

To Create a New Folder: 
1. Click the local or remote folder windows. 
2. Select one of the following methods: 

• Select [New Folder] from the [Commands] menu. 
• Right-click and select [New Folder]. 

3. When an input box appears, enter the name of the new folder. 
4. Press Enter.  

To View File Attributes: 
1. Select the file whose the attributes are to be checked from the local or remote folder 

windows.  
2. Right-click and select [Properties].  
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Session Log  
Xftp leaves two types of logs to files. One is for file management, such as renaming or deleting, 
and the other is for transfers. In the log folder, Xftp creates new folder for each execution date. 
In each folder, a file management log and a file transfer log are created, for each session.  

To Change Log Display in the Logs Window: 
1. Open the Options dialog box. 
2. Click the [Log] tab. 
3. Enter of the maximum display lines in the remote log window of [Max lines]. 

To Create a Log File: 
1. Open the Options dialog box. 
2. Click the [Log] tab. 
3. Click [Save log messages to files]. 
4. Click [OK]. 

To Delete a Log File: 
1. Open the Options dialog box.  
2. Click the [Log] tab.  
3. Click [Delete all log files].  

To Designate Log File Storage Days: 
1. Open the Options dialog box. 
2. Click the [Log] tab.  
3. Enter the storage days in the [Days to keep logs].  
4. Click [OK].  

To Designate a Log File Storage Folder: 
1. Open the Options dialog box. 
2. Click the [Log] tab. 
3. Click the browser button ([…]) for [Log folder location]. 
4. Select a folder in which to save logs from the Browse For Folder dialog box.  
5. Click [OK]. 
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Window Management 
Xftp offers convenient local and remote folder window management.   

To Move between Folder Windows: 
• Select a folder window to move by clicking the Session tab.  
• Select folder windows in order using Ctrl+Tab. 

To Refresh a Folder Window: 
1. Do one of the following: 

• Select [Refresh] from the [View] menu. 
• Right-click on the folder window and select [Refresh].  
• Click the standard [Refresh] button in the folder window. 

To Align Folder Window Content: 
1. Do one of the following: 

• Select [Arrange Icons by] from the [View] menu. 
• Right-click on the folder window and select [Arrange Icons by].  

To Change the Double-click Actions in a Folder Window: 
1. Open the Options dialog box. 
2. Click the [General] tab. 
3. Select [Double-click Action]. 

 Note 

Double-click Actions are Transfer, Open, Properties, and Edit.  
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